Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Preise glätten
#1
Liebe Community,

ich habe mir eine wirklich tolle Formel zusammengebastelt (nun ja, überwiegend im Inetrnet zusammenkopiert), die mir die Preise so glättet, wie wir es im Unternehmen haben möchten. Ich würde allerdings gerne noch etwas hinzufügen und finde die Lösung nicht:

Alle Preise ab 250 €, die auf *00,00 bis *09,99 enden, sollen auf 99,00 € des Vorhunderterschritts enden. Kostet ein Artikel berechnet also 306,34 €, soll der Preis mit 299,00 € ausgewiesen werden.

Kann mir da jemand helfen?

Hier meine bisherige Formel:

=WENN(A1=0;0;WENN(A1<100;AUFRUNDEN(A1;0)+(A1<0,5)-0,1;WENN(UND(A1>=100;A1<250);(AUFRUNDEN(A1*2;-1)/2)-0,1;WENN(A1>=250;AUFRUNDEN(A1/5;0)*5-(REST(A1;10)>5)))))

VG

David
Zitieren
#2
Hallo,
ich habe mich mal dran versucht, so sollte es passen:

=WENN(A1>250;WENN(((A1/100)-GANZZAHL(A1/100))<0,1;GANZZAHL(A1/100)*100-0,01;A1);A1)

Eine Beispieldatei mit einigen Testwerten ist hier: https://1drv.ms/x/s!Apqt9OZm11xkjg5HiskV...l?e=l0JyAz

Gruß
Heiko
Zitieren
#3
Ups, ich sehe gerade, ich habe mich verlesen und auf "*99,99" gesetzt. Statt "-0,01" muss daher natürlich "-1" in der Formel stehen...
Sorry
Heiko
Zitieren
Hinweis auf Angebot Excel-Inside - lang    Keine Lösung gefunden? Du kannst Dich gerne an unser erfahrenes Experten-Team wenden um dein Anliegen zu besprechen.
   Gerne erstellen wir auf dieser Basis ein völlig kostenloses und unverbindliches Angebot innerhalb weniger Stunden.
   Sende deine Anfrage einfach
per E-Mail an anfrage@excel-inside.de




Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste
Hinweis auf Angebot Excel-Inside - lang    Keine Lösung gefunden? Du kannst Dich gerne an unser erfahrenes Experten-Team wenden um dein Anliegen zu besprechen.
   Gerne erstellen wir auf dieser Basis ein völlig kostenloses und unverbindliches Angebot innerhalb weniger Stunden.
   Sende deine Anfrage einfach
per E-Mail an anfrage@excel-inside.de


Powerd and supported by Excel-InsideSolutions