Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Wenn-Funktion - Monatsprämien nach Monatsarbeitsstunden
#1
Star 
Hallo zusammen,  Wink

ich bräuchte eure Hilfe.

ich möchte mithilfe einer Wenn-Funktion die monatlichen Prämien für Mitarbeiter berechnen,
je mehr Arbeitsstunden sie monatlich haben, desto höher soll die monatliche Prämie sein.

Folgende Staffelung ist vorgesehen:
Zelle                    Erösstunden            --> Monatliche Prämie
A4                          170,00 Std.            --> 50,00 €
A5                          180,00 Std.            --> 100,00 €
A6                          190,00 Std.             --> 150,00 €
A7                          200,00 Std.             --> 200,00 €
A8                          210,00 Std.             --> 250,00 €

In den Zellen A4 bis A8 stehen die Daten, wer bei wie vielen Arbeitsstunden welche Prämie erhalten soll.

In der Zelle ab A14 (abwärts) sollen nun die Prämien bei verschiedenen Arbeitsstunden berechnet werden.

Folgende Staffelung ist vorgesehen:
Zelle                    Erösstunden            --> Monatliche Prämie mit Wenn-Funktion 
A14                          163,00 Std.            --> keine Prämie
A15                          168,00 Std.            --> keine Prämie
A16                          178,00 Std.             --> 50,00 €
A17                          194,00 Std.             --> 50,00 €
A18                          208,00 Std.             --> 50,00 €
A19                          214,00 Std.             --> 50,00 €   
A20                          181,00 Std.             --> 50,00 €

In B 14 gebe ich folgende Wenn-Funktion ein:
=WENN(A14>170;50;WENN(A14>180;100;WENN(A14>190;150;WENN(A14>200;200;WENN(A14>210;250;WENN(A14<170;"keine Prämie"))))))

Mein Ergebnis ist, das die monatliche Prämie nur bei Arbeitsstunden unter 170 (keine Prämie) und bis 180 Std. (50 €) richtig ausgegeben wird, sonst wird überall 50,00€ ausgegeben. 
Was ist hier falsch? Bei der Sonst-Bedingung habe ich eine neue Wenn-Funktion mit der neuen Bedingung eingegeben. Ist doch richtig, oder?

(siehe auch Anhang Excel-Datei "Prämienberechnung" Smile )

Bei 178 Std. müssten 50 € rauskommen, bei 181 Std. 100 €, bei 194 Std. 150 €, bei 208 Std. 200 € und bei 214 Std. 250 €.

Vielen Dank für eure Hinweise. Huh


Angehängte Dateien
.xlsx   Prämienberechnung.xlsx (Größe: 13,25 KB / Downloads: 3)
Zitieren
#2
Hola,
ich hab mir die Datei nicht angesehen aber ich weiß was falsch ist Smile
Ist ein rein logischer Fehler. Du musst von groß nach klein abfragen, also mit >210 anfangen, dann >200, dann >190 usw. Denn wenn in der Formel das erste mal eine Bedingung erfüllt ist, hört die Formel auf zu prüfen. Steht in A14 zB 300 dann ist direkt die erste Bedingung erfüllt, denn 300 ist >170. Mehr wird dann nicht geprüft.
Allerdings kann man das ganze mit einen Sverweis() viel kürzer erschlagen:
https://www.online-excel.de/excel/singsel.php?f=9
Gruß,
steve1da
Zitieren
#3
Hi,

Steve hat Deine WENN-Formel ja bereits perfekt erklärt. Und auch seine Erfahrung (ohne die Datei anzusehen) hat zum richtigen Link geführt.
Da ich mir die Datei aber gerade angeschaut habe, hier die Formel für B14:

=WENNFEHLER(SVERWEIS(A14;A$4:B$8;2);"keine Prämie")

und runterkopieren.

WENNFEHLER ist hier auch nur nötig, da Deine Vergleichsmatrix bei 170 beginnt. Würde sie bei Null beginnen (und für die Null steht rechts daneben bei "Monatsprämie" dann "keine Prämie", könnte man sich WENNFEHLER sparen. Weshalb das so ist, wirst Du mit Hilfe des Links bestimmt rausfinden ;-)

VG, Boris
Zitieren
Hinweis auf Angebot Excel-Inside - lang    Keine Lösung gefunden? Du kannst Dich gerne an unser erfahrenes Experten-Team wenden um dein Anliegen zu besprechen.
   Gerne erstellen wir auf dieser Basis ein völlig kostenloses und unverbindliches Angebot innerhalb weniger Stunden.
   Sende deine Anfrage einfach
per E-Mail an anfrage@excel-inside.de




Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste




Hinweis auf Angebot Excel-Inside - lang    Keine Lösung gefunden? Du kannst Dich gerne an unser erfahrenes Experten-Team wenden um dein Anliegen zu besprechen.
   Gerne erstellen wir auf dieser Basis ein Angebot.
   Sende deine Anfrage einfach
per E-Mail an anfrage@excel-inside.de


Powerd and supported by Excel-InsideSolutions