Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Probleme mit SVERWEIS
#1
Moin zsm,

dachte eigl immer, dass ich recht fit bin mit Excel. Jetzt hab ich das Problem, dass die Funktion "SVERWEIS" nicht mehr will bei mir. 
Da es sich um empfindliche Daten handelt mit denen ich aus beruflichen Gründen zu tun habe kann ich leider nicht direkt Screenshots hochladen aber ich versuche, es so gut wie möglich zu beschreiben.

Ausgangslage:
  • Mappe mit 3 Blättern, keine geschützten Elemente (selbst erstellt)
  • Blatt 1 enthält die meisten Daten die größtenteils manuell eingetragen sind
    (teilweise als SVERWEIS aus dem 2. Blatt)
  • Blatt 2 enthält eine Datenübersicht mit den wichtigsten Daten die sich aktuell nicht ändern
  • Blatt 3 enthält nur ein Schema, das nicht mit ! und/oder 2 verknüpft ist
  • die SVWERWEIS Funktionen in Blatt 1 funktionieren zum Beispiel:  
    Code:
    =SVERWEIS(A2;Data!$A$3:$J$256;5)

Problem:

Muss einige Daten (Namen) auslesen, habe als vorgabe die ID der Mitarbeiter. Habe die IDs dem Blatt 2 hinzugefügt und ein SVERWEIS genutzt um die Namen zu erhalten.
1. Spalten im Blatt: IDs
3. Spalte im Blatt: Namen

Input (die IDs der Mitarbeiter dessen Namen ich brauch) Spalte 12 und Output Spalte 13
Code:
=SVERWEIS($L3;$A$3:$C$257;3;FALSCH) < funktioniert, Ergebnis korrekt

=SVERWEIS($L4;$A$3:$C$257;3;FALSCH) < Fehler: Wert nicht verfügbar

die nachfolgenden Zeilen zeigen den selben Fehler
Habe die Formatierung aller Zellen gleich (Standard). Habe auch noch mal mit "Format übertragen" gearbeitet zur Absicherung.
Die Input IDs sind alle in Spalte vorhanden, es gibt also (eigl.) ein Match. Habe es auch schon mit der Formatierung "Zahl" versucht > selbes Ergebnis.
Zitieren
#2
Hola,
Screenshots hätten hier sowieso nichts genützt weil es scheinbar ein Format-Problem ist.
Eine Excel-Beispieldatei wäre hilfreich, weil aktuell ist es ein Stochern im Nebel.
Ergibt ISTZAHL() bzw. ISTTEXT() bei vermeintlich gleichen Werten, also L3 und die vermeintlich gleiche Zelle in Spalte A, immer das gleiche Ergebnis?
Gruß,
steve1da
Zitieren
#3
(13.06.2022, 09:38)steve1da schrieb: Hola,

Eine Excel-Beispieldatei wäre hilfreich, weil aktuell ist es ein Stochern im Nebel. (kommt im Anhang)
Ergibt ISTZAHL() bzw. ISTTEXT() bei vermeintlich gleichen Werten, also L3 und die vermeintlich gleiche Zelle in Spalte A, immer das gleiche Ergebnis?
(Tatsächlich nicht! nur bei der ersten Zeile von L)

Gruß,
steve1da


Angehängte Dateien
.xlsx   Beispiel.xlsx (Größe: 19,34 KB / Downloads: 4)
Zitieren
Hinweis auf Angebot Excel-Inside - lang    Keine Lösung gefunden? Du kannst Dich gerne an unser erfahrenes Experten-Team wenden um dein Anliegen zu besprechen.
   Gerne erstellen wir auf dieser Basis ein völlig kostenloses und unverbindliches Angebot innerhalb weniger Stunden.
   Sende deine Anfrage einfach
per E-Mail an anfrage@excel-inside.de


#4
[Bild: image.png]

Nachtrag

habe mir mal den Ursprung angeschaut und da könnte das Problem liegen mit der Formatierung

Die Zahlen in den Zellen lassen sich nicht als tatsächliche Zahlen formatieren
Zitieren
#5
Bin aktuell unterwegs und kann mir die Datei nicht anschauen. Aber versuch mal folgendes: schreibe in eine leere Zelle eine 1, kopiere diese, markiere die Werte in Spalte A, rechte Maustaste, Inhalte einfügen, Multiplizieren.
Das reine Ändern des Formats einer Zelle ändert noch nicht den Inhalt dieser Zelle. Eine als Text formatierte Zahl bleibt vorerst Text, bis man mit der Zelle interagiert, wie zB oben beschrieben.
Zitieren
#6
super - es hat funktioniert. Wieder was gelernt.

Vielen dank!  Heart
Zitieren
Hinweis auf Angebot Excel-Inside - lang    Keine Lösung gefunden? Du kannst Dich gerne an unser erfahrenes Experten-Team wenden um dein Anliegen zu besprechen.
   Gerne erstellen wir auf dieser Basis ein völlig kostenloses und unverbindliches Angebot innerhalb weniger Stunden.
   Sende deine Anfrage einfach
per E-Mail an anfrage@excel-inside.de


#7
Hallo,
ich weiß nicht mehr was los ist.
Normalerweise müsste deine Formel funktionieren.
Habe die gleiche Formel in LibreOffice Calc verwendet, funktioniert.
Auch bei OpenOffice Calc geht's.
Die Lösung von steve1da habe ich auch probiert, kein Erfolg.
Hat vielleicht ein anderer User eine Idee, warum das so ist?

MfG Günter
(Win10, MS-Office 2021)
Wenn gelöst, dann bitte Thema als "Erledigt" kennzeichnen.
Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste




Hinweis auf Angebot Excel-Inside - lang    Keine Lösung gefunden? Du kannst Dich gerne an unser erfahrenes Experten-Team wenden um dein Anliegen zu besprechen.
   Gerne erstellen wir auf dieser Basis ein Angebot.
   Sende deine Anfrage einfach
per E-Mail an anfrage@excel-inside.de


Powerd and supported by Excel-InsideSolutions