Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
Excel Tabelle Text aus Zelle in Formel übertragen
#1
Hallo,
für folgendes Problem habe ich keine Lösung gefunden.
In der erstellten Tabelle (siehe Bild) möchte ich in der Zelle "Ergebnis (E2)" den "Wert (A2)" mit der "Summe (D2)" addieren bzw. subtrahieren je nach dem was in der Zelle "+/- (B2)" steht. Bei der Standardformel "=SUMME(A2-D2)" möchte ich das "-" durch das Zeichen (+oder-) aus der Zelle "B2" ersetzen. Geht das? Und was muß ich in die Formel eintragen um das zu erreichen?

vielen Dank im Vorraus für eine Antwort

mit besten Grüßen an die Fachwelt
Ullrich Baltzer
[Bild: Text-auslesen-Excel.jpg]
Zitieren
#2
Hi,

das geht z.B. mit der alten Excel4Makrofunktion AUSWERTEN.
Selektiere Zelle E2, dann Strg+F3 (Namen definieren) - Neu - Name: Ullrich
Bezieht sich auf:
=AUSWERTEN($A2&$B2&$D2)

In Zelle E2 schreibst Du nun:
=Ullrich

Wenn Du die Formel dann runterkopierst, wandert die Zeile mit - also auf Zeile 3, 4 etc.

Hinweis: Die Mappe ist damit xlsm-pflichtig.

VG, Boris
Zitieren
#3
Hi,

noch etwas flexibler bist Du mit LAMBDA.
Definiere wieder einen Namen (Strg+F3), Neu, Name: Rechne
Bezieht sich auf:
=LAMBDA(WertX;Rechenzeichen;WertY;AUSWERTEN(WertX&Rechenzeichen&WertY))

In der Tabelle dann anzuwenden nach folgender Syntax:

=Rechne(WertX;Rechenzeichen;WertY)

Also bezogen auf Dein Bildbeispiel in E2 dann:

=Rechne(A2;B2;D2)

VG, Boris
Zitieren
Hinweis auf Angebot Excel-Inside - lang    Keine Lösung gefunden? Du kannst Dich gerne an unser erfahrenes Experten-Team wenden um dein Anliegen zu besprechen.
   Gerne erstellen wir auf dieser Basis ein völlig kostenloses und unverbindliches Angebot innerhalb weniger Stunden.
   Sende deine Anfrage einfach
per E-Mail an anfrage@excel-inside.de


#4
Moin!
Das Gleiche erreichst Du "etwas" einfacher mit
=A2+(B2&D2)
[Bild: 12poT05.png]

Gruß Ralf
Zitieren
#5
Moin Ralf,

für + und - hast Du natürlich Recht - und hier sollte das ja auch reichen. Die andere Variante kann aber auch dividieren, multiplizieren und potenzieren - da war ich gedanklich etwas "universeller" (in diesem Fall zu universell) unterwegs ;-)
Zitieren


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste




Hinweis auf Angebot Excel-Inside - lang    Keine Lösung gefunden? Du kannst Dich gerne an unser erfahrenes Experten-Team wenden um dein Anliegen zu besprechen.
   Gerne erstellen wir auf dieser Basis ein Angebot.
   Sende deine Anfrage einfach
per E-Mail an anfrage@excel-inside.de


Powerd and supported by Excel-InsideSolutions